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Lab 8 - PCB Design: EAGLE Software - 15 Marks - 2% of Final Mark 

Student Name: ____________________________________________________________ 

Student ID Number: _________________________     Date: ________________________  

Lab Rules:  

• Safety glasses are mandatory in the lab when the power is ON.  

• No food or drink is allowed in the lab.  

• Follow all SEMET Lab Rules (http://inside.senecacollege.ca/semet/code-of-behaviour) 

• Lab must be handed in by the end of the lab.  

Lab Objectives:  

1. Create a new printed circuit board (PCB) project using EAGLE software. 

2. Identify and select recommended parts in accordance with functional specifications. 

3. Design a schematic that conforms to the Electrical Rules Check and correct any errors. 

4. Design a PCB layout that conforms to the Design Rules Check and correct any errors. 

5. Create and manage board dimensions, trace widths, silkscreen text, and overall design. 

6. Create a set of manufacturing files (Gerbers) and upload them to MySeneca. 

Lab Materials: 

1. Lab computer for MySeneca and Autodesk EAGLE Software 

2. EAGLE Tutorial and Demo documents – available on LIN155.CORE 

 

Part 1: Introduction and Background 

All modern electronics rely upon Printed Circuit boards (PCBs) to provide a compact, efficient, and 
reliable connection between various components.  

PCBs are usually comprised of one or more layers of fiberglass and copper laminated together, 
where the copper is designed in specific patterns. Circuit boards serve two main purposes: 

- Provide a stable and rigid surface to mount components 

- Create electrical connections between the components 

  

http://inside.senecacollege.ca/semet/code-of-behaviour


 SEMET - LIN155 Lab 8        Pg 2 

To achieve these objectives, several features are etched into the copper of a PCB: 

Pads - Pads are the locations in which components are inserted into the board and soldered. 

Traces/Tracks - Traces are the metal paths used to connect various components together. 

 

 

Figure 1 - Soldered side of a printed circuit board (PCB), noting pads and traces. 

 

From Figure 1 above, students can practice doing the following: 

- Count the number of pads and traces present,  

- Identify the location and number of mounting holes, and  

- Locate the revision board number. 

 

Note: Students can design and print PCBs for free using SEMET resources. This lab paper will 
cover all the steps to create manufacturing files which can be sent to the PCB lab for printing.  

Keep this lab as a handy guide as you will be required to design PCBs for upcoming classes! 

  

Pad
 

Trace 
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Part 2:  Schematic Capture  6 Marks 

Our first step in PCB design is to create a Schematic based upon the parts that will be used in the 
board layout. This task will cover the process of creating a project and Schematic Capture. 

1. Launch Autodesk EAGLE from MyApps. The EAGLE control panel will open once loaded. 

2. Check that the working directory is where you want it: Options > Directories > Projects 

This will set the default location to store your projects. 

3. Create a new Project: File > New > Project 

Name the project: LIN155NxxL_LAB8_Lastname_Firstname 

Put your first and last name and lab section as part of the project name. 

4. Check that there is a green dot beside the project you just created. The green dot indicates 
which project is active, where any new schematic and board layout files will be created under. 

If another project is set as the active project, click on the black dot beside your project to set it 
as the active project, as indicated in Figure 2 below:  

 

Figure 2 - Set your new project as the active project, the green dot. 

5. Click your project name to highlight it, then add a new Schematic: File > New > Schematic 

 

Figure 3 - Highlight the project name before adding a new schematic. 
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The schematic editor will open. Get familiar with locations of the main controls and their uses. 

 

Figure 4 - Schematic Editor, side panel toolbar. 

We will follow each of these steps to complete the Schematic Capture design: 

a) Add Parts to the design by searching and selecting each one from the library, 

b) Connect the parts using the Net tool, to indicate where the traces will go, 

c) Run the ERC or Electrical Rules Check to check for errors and fix them. 
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6. Save and name the schematic within the schematic Editor: File > Save > Save as 

7. Begin adding parts using the “Add Part” button, found under the Component Controls section. 

 

Figure 5 - “Add Part” in the Component Controls section. 

Once you click Add Part, the parts search window will open. You can find all the devices you 
need for today’s lab work from here. (eg. resistors, capacitors, and inductors are under “rcl”.) 
Components can be found either by navigating through the categories or by using Search. 

 

Figure 6 - Parts search window is used to add a part. 

 Today, you will create a printed circuit board with three thru-hole parts with these properties: 

- one Resistor: 1 kΩ, 1/4 W  
- one LED: 5 mm  
- one Connector: two-position, 2.54 mm/0.1” pitch (also called a header pin) 
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8. Find the 1/4 W Resistor: Scroll down the list and locate RCL > R-US_ > R-US_207/12 

Select the part and place it on the schematic. Press ESC to return to the parts search window. 

 

Figure 7 - Adding a resistor to the schematic diagram. 

9. Next, place the LED into the circuit: led > LED > LED5MM 

You can rotate the part by right-clicking before placement. 

 

Figure 8 - Schematic showing two parts, unconnected. 

10. Now add a 2-position pin header to the schematic: pinhead > PINHD-1X2 > PINHD-1X2 

11. Using the “Net” tool, connect the circuit parts together as shown in Figure 9 below: 

 

 Figure 9 - Select Net to connect the parts together. 



 SEMET - LIN155 Lab 8        Pg 7 

12. Click on the “ERC” button from the Measurement and ERC section. 

  
  

The ERC Errors window will pop up and highlight any errors or warnings, such as unconnected 
pins, accidental connections between power and ground, missing values, and others. 

Review all errors and any warnings and fix them if necessary. For example, for any missing 
values, select the part and right-click it again to select its Value in the menu, then fill it in. 

If no correction is needed on the error, click on “Approve” to remove it from the list. 

When the schematic is complete and error-free, we can proceed to the board layout design. 

 

 Call your instructor for a signature: __________________  ( 1  2  3  4  5  6  Marks) 

 

 

Part 3: PCB Layout 6 Marks 

Our second step in PCB design is to convert the schematic information into a physical board 
layout. This task will cover the process of the PCB Layout. 

1. Click the Generate/Switch to Board button to switch to the board editor: 

 

Figure 11 - Find the "SCH BRD" button at the top of the screen. 

2. A message box will appears asking you to create a board from the schematic. Click Yes.  

Figure 10 - Click “ERC” to run the Electrical Rules Check. 
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The board editor should open. Get familiar with locations of the main controls and their uses. 

 

Figure 12 - Board Editor window, side panel toolbar. 

 

We will follow each of these steps to complete the PCB Layout design: 

a) Create the board outline and set its dimensions, 

b) Place the parts within the board dimensions in their desired locations, 

c) Replace all schematic Nets with physical copper Traces on the board, 

d) Add text to the silkscreen layer to indicate name, revision, etc. 
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Board Outline 

3. Set the active layer to the dimensions layer, as shown in Figure 13: 

 

Figure 13 - Dimensions layer selected. 

4. Select the Move tool from the Placement Controls menu. 

 

Figure 14 – “Move” in the Placement Controls section. 

5. Click a side from the yellow dimension line and resize the whole rectangle to 2” x 2”. 

Recall: 1000 mils = 1”. 

 

Figure 15 - Yellow dimension box is set to 2" x 2". 

Component Placement 

6. Ensure the Move tool is selected and move each part into the board outline area. When picking 
up parts, aim to click the yellow + in their centre. Rotate them while they are selected by right-
clicking. Move the parts into place as shown in the following diagrams. 
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Figure 16 - Move the LED and rotate it into place. 

    

Figure 17 - Move the Resistor into place.  Figure 18 - Move the Connector into place. 

Traces 

Note: The “unrouted” yellow wires connecting the parts together indicate where the traces will go. 

7. Select the Bottom layer as the active layer. Traces made on this layer will appear in blue. 

 

Figure 19 - Select the Bottom layer. 

8. Click on the “Route Airwire” button from the Routing Controls section. 

 

Figure 20 - Select the Route Airwire button. 

9. Set the trace width to 50 mils. This will control how wide the traces will be in the layout. 

 

Figure 21 - Set trace width to 50 mils. 
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10. Click on the top pin of JP1 to start routing the trace. Complete the trace all the way to R1. 

    

 

 

 

 

 

 

 

 

11. Continue routing all traces so that there are zero remaining unrouted wires.  

Silkscreen Text 

12. To add text to the silkscreen layer, change the layer to tNames. 

 

Figure 23 - Change the layer to tNames. 

13. Click on the “Text” button in the Routing Controls section. Enter your first and last name and 
add it to the board as shown in Figure 24. 

 

Figure 24 - Finished board with all parts and text in place. 

 

 Call your instructor for a signature: __________________  ( 1  2  3  4  Marks) 

 

Figure 22 - Complete the first trace between JP1 and R1, labelled N$1. 
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Design Rules Check (DRC) 

14. Next, we’ll run the Design Rule Check (DRC) to ensure our board layout is free from errors 
such as missing traces, missing part values, etc. 

Click on the “DRC” button shown below to open the DRC (Design Rules Check) window. 

 

 

The DRC window will pop up. Don’t click Check yet! We first need to set up some dimensions. 

 

Figure 26 - DRC window, default screen. 

15. Click on the Clearance tab and set the following settings to 14mil: 

 

Figure 27 - Set the minimum distances between copper features: traces, pads, and vias. 

Figure 25 - Select the DRC button from the toolbar. 
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16. Click on the Sizes tab and set the following settings, including Minimum Width = 18mil: 

 

Figure 28 - Set the minimum width of traces and drill holes. 

17. Now we can click “Check” and run the DRC process. 

 

Figure 29 - DRC window shows errors on the current design. 

The DRC Errors window will pop up and highlight any errors or warnings, such as unconnected 
pins, accidental connections between power and ground, missing values, and others. 

Review all errors and any warnings and fix them if necessary. 

If no correction is needed on the error, click on “Approve” to remove it from the list. 

When the schematic is complete and error-free, we can proceed to the Gerber Generation. 

 

 Call your instructor for a signature: __________________  ( 1  2  Marks) 
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Part 4:  Gerber Generation & File Submission   3 Marks 

The final stage of PCB design is to create a set of manufacturing files that the machine can use to 
physically create the board. Each layer of the PCB design will be exported into its own Gerber file. 
This task covers the steps to export all Gerber files. 

1. In the PCB editor, click File > Generate CAM Data and the CAM Export File List will open. 

 

Figure 30 - CAM Export File List shows all the Gerbers generated from the exporting process. 

Extra files will be generated that may not always be used; you can always delete them later.  

A very minimum, you must have the following Gerbers to manufacture a board: 

• Board Outline Layer 

• Drill Files (Plated and non-plated) 

• Bottom-side Copper Layer 

• Top-side Silkscreen Layer 

eg. If you have a double-sided board, you will also need to include the Top-side Copper Layer. 

2. Click OK and select the location to have all the Gerbers exported.  

3. Using a program like File Explorer, navigate to your Gerbers folder. Put all Gerber files, plus 
the original .SCH and .PCB files, into a 7zip archive. Name the file in the following format: 

LIN155NxxL_LAB8_LASTNAME_FIRSTNAME .7z 

Your first and last name and lab section should be part of the 7zip archive name. 
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4. Upload the .7z file containing the schematic and PCB files, and all Gerbers, to Blackboard as 
per your professor’s instructions. 

Your instructor can check your 7zip archive on your screen to confirm you have included all the 
files, but no signature is required for this section. 

 

No signature. You must upload your .7z file to get full marks for the lab.   ( 1  2  3  Marks) 

 

Total Marks:           /15 Comments: ________________________________________ 

      ________________________________________ 

 

 

Lab 8 Checklist: 

At the conclusion of this week’s lab, you should be comfortable explaining the following items: 

 Explain how the EAGLE applications works together to produce PCB designs. 

 How do the schematic and board editors work, and how are they different from each other. 

 Justify your selection of components from the parts library based on their size and function. 

 Understand the software rules for inserting, rotating, and modifying components. 

 Explain the importance, and differences between, the DRC and ERC. 

 Explain the purpose of the board outline and how to create one. 

 Understand how the clearances and design rules affect the outcome of the PCB design. 

 Explain how to create the Gerber files for manufacturing, and what data they each contain. 

 Practice sending files to a 7zip archive, which is the file format our PCB Lab accepts by email. 
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